Vimeo social icon won't go away!

Homepage Forums Pro Support Forum BoldR Pro BoldR Pro Support Vimeo social icon won't go away!

Vimeo social icon won't go away!

This topic contains 8 replies, has 2 voices, and was last updated by  iceable 4 months, 3 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #21165
    Vimeo social icon won't go away!

    inseromarketing
    Participant

    Hi,

    I used a vimeo social icon, but now I want it gone. I’m going into appearance > theme options > social media and removing the link, but once I click save, the link comes back and the social icon won’t go away!

    Please, could you tell me what is happening? It’s not letting me delete the link and seems to be caught in some weird loop!

    Many thanks,
    Stuart

    #21166
    Reply to: Vimeo social icon won't go away!

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    Hi Stuart,

    If I understand correctly, when you remove the link, hit save and refresh the settings panel, the link is still there. To put it otherwise, settings are not saved when you click the save button, is that so?

    This would indicate something wrong with javascript in your admin panel, which would prevent the settings panel and save feature from working properly.
    Usually one of these should help:
    – Make sure everything on your site is up to date (WP, theme, plugins)
    – Clear your browser’s cache or try with another browser
    – Try to temporarily disable ALL plugins on your site to rule out a potential conflict caused by one of them

    If I didn’t get it correctly and the link is effectively gone from settings but still there on the front-end, I would immediately think of caching:
    – if you have a caching plugin, go to its settings page and click the button to clear/refresh/delete/purge the cache (any of these words means the same in this context)
    – if you don’t have a caching plugin but have some form of caching from your host or a CDN like cloudflare, you’d want to look at these settings to purge the cache.

    #21173
    Reply to: Vimeo social icon won't go away!

    inseromarketing
    Participant

    Correct.

    This is very odd. I tried your suggestions and it did not help at all.

    – Everything is up to date
    – I disabled all plugins and tried to remove the link, this didn’t help
    – I deleted cache (chrome) and tried other browsers. No luck either.

    I am not using a caching plugin, so it can’t be that. I don’t really know anything about the last point, so it seems I’m stuck with a Vimeo link 🙁

    #21175
    Reply to: Vimeo social icon won't go away!

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    As a quick and dirty alternative, you can use the following CSS to hide it:

    #nav-social .vimeo-square {
        display: none;
    }

    The link will still be there in the source code of the page, but it won’t be visible anymore.

    You can add this code to Appearance > Code & CSS > Custom CSS. Or if it doesn’t save either for some reason, you can also add it to Customizer > Additional CSS; both actually works the same.

    If no setting change seems to save however, there is definitely something wrong that may cause further issues at some point.
    I’m really not sure what it is now that you have tried to main troubleshooting steps without success, but I can try to have a look at it for you if you wish to provide me with a temporary admin login.

    #21176
    Reply to: Vimeo social icon won't go away!

    inseromarketing
    Participant
    This reply has been marked as private.
    #21177
    Reply to: Vimeo social icon won't go away!

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    I just had a look around and I confirm the settings panel won’t save anything because /wp-admin/admin-ajax.php returns a 404 error.
    This file needs to be pinged to actually save the settings, and it is also used for quite a few other features in WordPress.

    Digging a bit more it seems that Imunify360 is blocking access to this file.

    If this doesn’t sound familiar, it is probably a feature implemented by your hosting provider. Try to look around the settings in your account with them, or contact them with this info and ask them to adjust the settings and either disable it or at least unblock admin-ajax.php

    #21178
    Reply to: Vimeo social icon won't go away!

    inseromarketing
    Participant

    Great – thank you for looking!

    I have sent a message to my hosting provider to ask them to have a look. I will keep you updated once they respond.

    Hopefully, this is down to them. Otherwise, the mystery continues…

    #21179
    Reply to: Vimeo social icon won't go away!

    inseromarketing
    Participant

    Just updating this –

    I contacted my hosting provider who said ‘We’ve disabled the rule that was affecting you to stop it causing problems’, which seems to have resolved the issue (at least it let me get rid of the Vimeo logo!).

    Thank you for diving into the problem to help me find the issue and get this quick resolve. Much appreciated.

    #21180
    Reply to: Vimeo social icon won't go away!

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    Brilliant, glad this could be sorted quickly, and thanks for letting me know!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.


PayPal Verified
Secured by PayPal
Secure Credit Card payments powered by Stripe
SiteLock