Update to the same version I already have

Homepage Forums Pro Support Forum Blackoot Pro Blackoot Pro Bug Reports Update to the same version I already have

Update to the same version I already have

This topic contains 3 replies, has 2 voices, and was last updated by  Cheyenne 2 years, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #14845
    Update to the same version I already have

    Cheyenne
    Participant

    This is weird: On Solitary Pilot (http://solitarypilot.incyanity.net/) WordPress is telling me I can update Blackoot to version 1.1.6 but I already have that version. If I proceed with the update, I get an “update successful” message but the update reminder doesn’t go away.

    I’m not getting this on Incyanity so I wonder if this bug has anything to do with the child theme I have on Solitary Pilot?

    Attachments:
    You must be logged in to view attached files.
    #14848
    Reply to: Update to the same version I already have

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    Hello,

    This may indeed be a glitch that happens when using a child theme.

    The update checker appears to mistakenly compare the version number of the “current theme” (which happens to be the child theme if you use one) against the version number on the server to determine whether an update is available to download.

    The reminder should therefore go away if you change the child theme’s version number to 1.1.6 – this is not an actual solution of course, but it would confirm this is what happens.

    You can also just leave it “as-is” for now since this doesn’t affect any functionality.

    Thanks for reporting this, I’ll look into it more closely and fix it with the next update.

    • This reply was modified 2 years, 3 months ago by  iceable.
    #14851
    Reply to: Update to the same version I already have

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    Just released Blackoot Pro 1.1.7 with a fix for this, the update checker now correctly uses the parent’s theme version number to do its thing when a child theme is being used.

    Once you apply this update the reminder will go away as it should.

    Thanks again for the bug report 🙂

    #14888
    Reply to: Update to the same version I already have

    Cheyenne
    Participant

    It worked! Thanks!

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Update to the same version I already have’ is closed to new replies.


PayPal Verified
Secured by PayPal
Secure Credit Card payments powered by Stripe
SiteLock