Translation Issue (German) with BoldR (and mabye the other Themes)

Homepage Forums Community Ideas, tips, tricks and external resources Translation Issue (German) with BoldR (and mabye the other Themes)

Translation Issue (German) with BoldR (and mabye the other Themes)
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #7025
    Reply to: Ideas, tips, tricks and external resources

    Hi, i’am using (and loving) the BoldR Lite Theme for my german Production-Blog-Homepage and thinking about upgrading to the Pro-Version, but there is a persistant translation-issue with the Comments-Count-Preview on the Mainpage (and other pages that show overviews of aviable posts) which is bothering me.

    If there are no comments on a post, it says “Nein Kommentar” which is grammatically incorrect.
    “Nein” means No in German, but its not relatet to this kind of context. If someone says “Nein” in Germany its always or mostly the Answer to a Questsion … so “Nein!” means “No!” with a “!” in this case.

    The correct word in connection with no existing comment on a Post would be “Kein” or “Keine”.
    “Kein” is mostly related to “one” non-existing thing, so “Kein Kommentar” translates to “There is currently no comment”. Alternatively you also could use “Keine Kommentare” (with an “e” at the end of both words) whitch means “There are no comments”, so it points to more than one non-existing thing…but this makes not a huge difference, both spelings would be correct in this context.I would prefer the first method.

    Hope this helps and will be fixed in the near future.
    Please don’t flamewar me, if my english is not the best…no one is perfect, as you know 😉

    If you want, you can check out my Page here:

    Greetings from Germany,

    Reply to: Translation Issue (German) with BoldR (and mabye the other Themes)
    Happy with my help?
    Buy me a beer!

    Hello, and thank you very much for reporting this issue.
    To be honest this translation is a contribution from another user (in boldr lite, you will find the credits in readme.txt) and I only have some really basic knowledges of German.
    However I understand that in the context of comments, “No” should be translated to “Kein” instead of “Nein”!
    I can also understand how the translator made this mistake: translation process consists of translating strings one by one, out of their context.

    This will be fixed in the next update.

    To fix it right now on your end before the next update, you have two options:

    – You could edit the translation itself, which is made of de_DE.po and, both located in the /languages folder of the theme. You will need poedit (free software) for this.

    – Second option is easier: go to Appearance > Editor and edit index.php and single.php.
    In both of these files, you will find this lins:

    <?php comments_popup_link( __( 'No', 'boldr' ), __( '1', 'boldr' ), __( '%', 'boldr' ), 'comments-count', '' ); ?>

    Here you can directly replace ‘No’ with ‘Kein’, and leave the rest as is. This will override the translation files for this word only.

    Usually, I would not recommend doing it this way, but in this case it is okay since when you update to the next version, your changes will be replaced by the original files, and the translation file will be fixed, so everything will be alright.

    Note: All of these apply to BoldR Lite and Pro. The next update of BoldR Lite is planned for next week, and the next update of BoldR Pro will be released just before WordPress 3.9 (planned this month).

    Reply to: Translation Issue (German) with BoldR (and mabye the other Themes)

    I’ll wait for the Update 😀

Viewing 3 posts - 1 through 3 (of 3 total)
  • The topic ‘Translation Issue (German) with BoldR (and mabye the other Themes)’ is closed to new replies.

256 bit SSL. 100% secure transactions and data encryption
PayPal Verified
Secured by PayPal
Secure Credit Card payments powered by Stripe