No sidebar with 2 plugins

Homepage Forums Pro Support Forum Blackoot Pro Blackoot Pro Bug Reports No sidebar with 2 plugins

No sidebar with 2 plugins

This topic contains 7 replies, has 2 voices, and was last updated by  Xisca 1 year, 9 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #17441
    No sidebar with 2 plugins

    Xisca
    Participant

    I use the plugin “Simple YouTube Gallery” and “MF Gig Calendar” and in the pages that are activated these plugins sidebar disappears

    This is the url where the plugin video shows: http://deepbluelivemusic.com/videos/

    This is the url where the plugin events shown: http://deepbluelivemusic.com/shows/

    I have enabled maintenance mode, to see the web can use the following data:

    user: Gaby
    Pass: sedientodecotilleo

    In the configuration of each page I is activated the sidebar is displayed on the right, if I delete the code pages plugins again show the sidebar.

    I tried it with another template and plugins and sidebar display properly, only happens with your template “blackoot-pro”

    Please, I need help to solve this, I do not want to change my web plugins.

    Thank you

    #17442
    Reply to: No sidebar with 2 plugins

    Xisca
    Participant

    Sorry, just about the plugin “Simple YouTube Gallery” with the other works well

    #17457
    Reply to: No sidebar with 2 plugins

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    Hello,

    Searching for “Simple YouTube Gallery” in the wordpress.org repository returns a lot of results with no exact match so I’m not sure which one it is you are using.

    Can you please post a link to this plugin in the WordPress repository so I can make sure I use the right one for testing ?

    #17458
    Reply to: No sidebar with 2 plugins

    Xisca
    Participant
    #17459
    Reply to: No sidebar with 2 plugins

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    Thanks, I just ran a quick test but could not reproduce the issue: I added a video and made a “gallery” on a new page with this plugin and the sidebar is working just fine.

    I noted however that this plugin turns the page you use it on into an “index” (like the blog index page) which negates every “page setting” options. The default settings for the blog index apply instead so I get the default sidebar. If you were trying to use a custom sidebar on this page then you may want to check this.

    If this doesn’t help then the issue on your site is either a larger conflict with another plugin, or might be specific to your settings.

    In the first case, can you try to disable every other plugins and see if it works?
    In the second case I can offer to have a closer look directly on your site to try and find out what goes wrong if you wish to provide me with a temporary admin login. (Don’t forget to check the “set as private reply box” when posting sensitive info!)

    It must be noted for the record that this plugin is has not been updated in a year, its last version is marked as “compatible up to 4.2.8” – while the current WP version is 4.5.2 – and it throws a large amount of PHP notices and errors especially in the admin area.
    I understand you don’t want to spend time finding and setting up another one, but please keep in mind that you may encounter some further issues along the way with this one.

    #17460
    Reply to: No sidebar with 2 plugins

    Xisca
    Participant
    This reply has been marked as private.
    #17462
    Reply to: No sidebar with 2 plugins

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    Thanks, I could have a closer look at your setting and this time I could replicate the issue on my own testing site.

    There is a bug in the plugin that prevents the page template from retrieving the option that are set in the “icefit page settings” box.

    (Specifically, the plugin fails to call wp_reset_postdata() after its custom loop to retrieve all videos, as a result the WordPress core function get_the_ID() returns the ID of the last video instead of that of the current page)

    I cannot fix the plugin since I am not its author, but I can craft an alternative solution to make this work: using a child theme with a default page template that uses the default sidebar regardless of the “page settings” options will circumvent the issue.

    I’m attaching to this reply a child theme with a custom page template for you:
    – Download and install it on your site just as if it was a new theme.
    – Once it is active, edit your “videos” page and look for the “Page Attributes” box on the right side.
    – Under “Template”, select “Page No Settings” and it should fix your sidebar issue.

    Attachments:
    You must be logged in to view attached files.
    #17478
    Reply to: No sidebar with 2 plugins

    Xisca
    Participant

    Many thank you very much, works well.

    Very good support !!

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘No sidebar with 2 plugins’ is closed to new replies.


PayPal Verified
Secured by PayPal
Secure Credit Card payments powered by Stripe
SiteLock