Internet explorer stretching buttons to full width..

Homepage Forums Free Support Forum Silverclean Lite Silverclean Lite Support Internet explorer stretching buttons to full width..

Internet explorer stretching buttons to full width..

This topic contains 3 replies, has 2 voices, and was last updated by  bsuk 3 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #8665
    Internet explorer stretching buttons to full width..

    bsuk
    Participant

    Hi, I have the “out of the box” Silverclean with no modifications.
    Everything displays fine, except in Internet Explorer on Windows (version 9)..
    The buttons are stretched out across the entire width of the screen, like so:

    http://www.benshaw.org.uk/misc/silverclean_ie.png

    Any idea what causes this, or how to fix it in IE?
    Many thanks!

    By the way, I love the theme and I’m definitely planning to purchase the Pro version as soon as my company are able to sign off the cost.

    #8674
    Reply to: Internet explorer stretching buttons to full width..

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    Hello,

    It looks like your IE is set to “compatibility mode”, which makes it behave like IE7 and cause this result. (Note that IE7 is greatly outdated and not supported anymore).

    Silverclean contains a meta tag that tells IE not to use compatibility mode, but your own settings can override this.

    So what you want to do is make sure your IE is properly configured not to use this compatibility mode when not necessary (see: http://support.microsoft.com/kb/2536204 for more info about this mode in IE9)

    #8676
    Reply to: Internet explorer stretching buttons to full width..

    bsuk
    Participant

    Thank you very much for identifying that.
    My browser was somehow stuck in IE7 developer mode..?!! From IE8 onwards the buttons display correctly as you’d hope.

    Many thanks indeed.

    #8732
    Reply to: Internet explorer stretching buttons to full width..

    bsuk
    Participant

    For anyone else who hits this problem, I added this line to .htaccess:

    Header set X-UA-Compatible “IE=edge,chrome=1”

    This forces IE to use the latest version of it’s rendering engine.

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Internet explorer stretching buttons to full width..’ is closed to new replies.


PayPal Verified
Secured by PayPal
Secure Credit Card payments powered by Stripe
SiteLock