dont work BlogPosts Widget thumbnail

Homepage Forums Pro Support Forum Chooko Pro Chooko Pro Bug Reports dont work BlogPosts Widget thumbnail

dont work BlogPosts Widget thumbnail

This topic contains 4 replies, has 2 voices, and was last updated by  iceable 2 years, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #14876
    dont work BlogPosts Widget thumbnail

    Сергей
    Participant

    okay. my site i-vkusno-i-prosto.com.
    on my site thumbnail in BlogPosts widget works incorrect.
    because in the “icefit-blogposts.php” in 194 string code “$thumbnail = wp_get_attachment_image_src( get_post_thumbnail_id(), ‘thumbnail’)”
    but I found solution, instead this I write “$thumbnail = the_post_thumbnail();”

    please can you say for me, why your code doesn’t worked on my site.

    PS. Sorry for my mistakes, and I can give you Russian translate Chooko Pro.

    Attachments:
    You must be logged in to view attached files.
    #14878
    Reply to: dont work BlogPosts Widget thumbnail

    Сергей
    Participant

    I use Chooko Pro 1.4.2 on WordPress 4.1.3

    #14881
    Reply to: dont work BlogPosts Widget thumbnail

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    Hello,

    This code is working correctly, however it could have been causing an issue on your site if your thumbnails were generated prior to using this theme.

    If you were using another theme with different settings when you uploaded your images, then thumbnails could have been generated in a different way.

    When this happen, the best thing to do is to “regenerate the thumbnails” for your images, so WordPress will re-create all thumbnails according to the current theme settings.

    This free plugin does exactly this at the click of a button in just a few minutes: https://wordpress.org/plugins/regenerate-thumbnails/

    Running it should fix your issue completely without the need to change any code from the theme.

    #14885
    Reply to: dont work BlogPosts Widget thumbnail

    Сергей
    Participant

    but “regenerate the thumbnails” didn’t help me, o try use this plugin. =\
    this code work now “$thumbnail = the_post_thumbnail();” and I’m glad

    #14899
    Reply to: dont work BlogPosts Widget thumbnail

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    I’m now sure how or why thids plugin wouldn’t work for you, but if your modified code does the trick and you are happy with it, then I guess everything is fine! 🙂

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘dont work BlogPosts Widget thumbnail’ is closed to new replies.


PayPal Verified
Secured by PayPal
Secure Credit Card payments powered by Stripe
SiteLock