changes after upgrade to the newest version

Homepage Forums Pro Support Forum BoldR Pro BoldR Pro Bug Reports changes after upgrade to the newest version

changes after upgrade to the newest version

This topic contains 7 replies, has 2 voices, and was last updated by  iceable 3 years, 3 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #9672
    changes after upgrade to the newest version

    lukszleper
    Participant

    Hello,

    may I ask you to help me fix some problems, which appeared after upgrade to the newest version?
    Sidebar on post page appears under the text instead of the right hand side. How to change it?
    Buttons on the post pages <previous post>, <next post> – where to change it?
    It is translated in polish, but previously it was changed to <previous project>, <next project> instead of posts.
    Problems are on the following page: lsprojekt.pl
    Thank you as usual for your great support!
    Best regards,
    Dagmara

    #9675
    Reply to: changes after upgrade to the newest version

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    Hi, you previously added some custom css to completely hide the sidebar from blog index and single posts – however with the latest version this code doesn’t work exactly as expected anymore!

    You especially have this currently in Appearance > Theme Options > Main Settings > Custom CSS:

    @media only screen and (min-width:960px){
    	.blog #page-container.with-sidebar,.single-post #page-container.with-sidebar{width:960px}
    	.blog .post-contents,.single-post .post-contents{width:835px}
    }
    
    @media only screen and (min-width:768px) and (max-width:959px){
    	.blog #page-container.with-sidebar,.single-post #page-container.with-sidebar{width:768px}
    	.blog .post-contents,.single-post .post-contents{width:652px}
    }

    Remove this for the sidebar to display correctly.
    Or if you’d rather hide the sidebar completely as before, change this part:

    .single-post #sidebar-container, .blog #sidebar-container{ display:none; }

    into this:

    .single-post .sidebar-container, .blog .sidebar-container{ display:none; }


    Previous/next buttons:

    There are two ways to change them: either update the pl_PL.po and pl_PL.mo files using poedit (best practice but somewhat advanced), or you can just edit functions.php from the theme (you can edit it from Appearance > editor) and find and change it on these two lines:

    next_post_link('%link', __('Next Post', 'icefit') ),
    previous_post_link('%link', __('Previous Post', 'icefit') ),

    For the blog index, you can edit these lines from index.php

    ?><div class="previous"><?php next_posts_link( __('Previous Posts', 'icefit') ); ?></div><?php
    ?><div class="next"><?php previous_posts_link( __('Next Posts', 'icefit') ); ?></div><?php

    #9699
    Reply to: changes after upgrade to the newest version

    lukszleper
    Participant

    Hi,

    thank you for your help.
    Unfortunately not everything is possible to translate in .php files.
    Previously I have install code styling localization, but after the upgrade there is an error and I don’t know, how to fix it:

    Error: The actual loaded translation content does not match the textdomain: icefit
    Expect, that any text you translate will not occure as long as the textdomain is mismatching!
    This is a coding issue at the source files you try to translate, please contact the original Author and explain this mismatch.

    Could you help me? I have still some english words on the page and I would really like to avoid it :/
    Thank you in advance for any hints 🙂
    Best regards,
    Dagmara

    #9703
    Reply to: changes after upgrade to the newest version

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    Hi, Codestyling Localization (https://wordpress.org/plugins/codestyling-localization/) is marked as compatible up to WordPress 3.5.2 and has not been updated since Feb.2013 – so I would be careful when using it!

    However there might be something wrong in your settings, since the textdomain for BoldR is still ‘icefit’ and hasn’t changed in the latest version. You may also want to make sure the “loaded translation” is the one from BoldR 1.6 and not from a previous version.
    If you can’t fix it, I suggest you try to:
    – Contact the plugin author for support (if they still support this plugin)
    – Use another plugin for translation
    – Or, update the translation file yourself with poedit (takes only a few minutes – see below)

    The pl_PL translation file already exist in the theme, but they are incomplete (they are adapted from an user-contributed translation for BoldR Lite, and the Pro version contains more text to be translated). To update and complete it:
    – Download poedit (free and available for win/mac/linux): http://poedit.net/download
    – Download the theme and unzip it to your computer.
    – Open the theme folder, and go to /languages
    – Open pl_PL.po with poedit
    – You can now translate all missing strings in the poedit interface
    – Once done, save the file (this will automatically update both pl_PL.po and pl_PL.mo at the same time)
    – Now replace these two files in /boldr-pro.1.6.0/languages/ on your site via FTP
    – Done!

    #9816
    Reply to: changes after upgrade to the newest version

    lukszleper
    Participant

    Hi,

    thank you for above recommendation.
    I have downloaded loedit, traslated all needed texts, installed FTP and uploaded the file to the server.
    I have also deactivated codestyling localization.
    Unfortunately it doesn’t work, I have still few issues:

    1. I see ‘posted in’, when I go to the first tab called ‘projekty’ (not translated),
    2. Months are in english, could you help me translate it into polish
    3. Button more doesn’t have frame, probably I have deleted some part of code :((((

    Thank you once again for your GREAT help 🙂
    Best regards,
    Dagmara

    #9818
    Reply to: changes after upgrade to the newest version

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    1. That’s weird, this string is translatable and is even already there in the po file – it even works on my test site if I switch to Polish, “posted in” becomes “napisano w”. You can either make sure your po/mo files are up to date and fully translated, or you can just translate this string directly in index.php and single.php if you feel lazy 🙂

    2. Now that’s interesting, looks like there’s an additional bit of code needed for WordPress to be able to translate dates correctly (thanks for pointing this out, I’ll update this in the next version!) Please try to edit index.php and change this line:

    <span class="month"><?php the_time('M'); ?></span>

    To:

    <span class="month"><?php echo date_i18n( 'M', strtotime( get_the_time('Y-m-d') ) ); ?></span>

    This should allow WordPress to return the month in the correct format and language. If it does work as intended then you can do the same in single.php

    3. Looks like you have unintentionally translated the CSS class name as well as the text to display! In functions.php:

    return '<div class="więcej"><a href="'. get_permalink( get_the_ID() ) . '">'. __("więcej", 'icefit') .'</a></div>';

    The class should be “read-more”, no matter the language:

    return '<div class="read-more"><a href="'. get_permalink( get_the_ID() ) . '">'. __("więcej", 'icefit') .'</a></div>';

    #9822
    Reply to: changes after upgrade to the newest version

    lukszleper
    Participant

    Hello,

    thank you for your quick reply.
    1-first and 3-third issues are solved – great!
    I have changed the date format as you mentioned above, but nothing hapened.
    Maybe I could somehow translate the names of all months in poedit?

    Have a great weekend.

    Best regards,
    Dagmara

    #9823
    Reply to: changes after upgrade to the newest version

    iceable
    Keymaster
    Support
    Happy with my help?
    Buy me a beer!

    Unfortunately you can’t translate them through poedit because the months are returned by WordPress core functions (the_time()), and not coded into the theme.

    However the code I suggested above did work on my test site (in Polish) so maybe there’s something wrong or missing in your WP install or settings.
    You should make sure that:
    – you have the 3 following files in /wp-content/languages/ (this the the language folder in wp-content, not in the theme!): pl_PL.mo, pl_PL.po, pl_PL.php
    (If you don’t have them, you can get them by downloading and unzipping the Polish wordpress package from pl.wordpress.org)
    – In Settings > General, at the bottom Site Language is set to pl_PL
    – If you have a caching plugin, make sure to clear the cache!
    – You clear your browser’s cache and refresh the page

    Let me know if you still have some trouble with this and I’ll try to help further sorting this out!

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘changes after upgrade to the newest version’ is closed to new replies.


PayPal Verified
Secured by PayPal
Secure Credit Card payments powered by Stripe
SiteLock